Login



agorum core
Willkommen, Gast
Fehlermeldung bei Anlage neuer Benutzer (1 Leser) (1) Gast
Zum Ende gehen Neues Thema Beliebt: 0
THEMA: Fehlermeldung bei Anlage neuer Benutzer
#10518
tjahn (Benutzer)
Fresh Boarder
Beiträge: 2
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Fehlermeldung bei Anlage neuer Benutzer vor 3 Monaten, 2 Wochen Karma: 0  
Hallo,

wir testen gerade Agorum Core Open.
Bisher recht erfolgreich. Jetzt erscheint allerdings beim Anlegen eines neuen Benutzers folgende Fehlermeldung:

Duplicate entry '2147483647' for key 'PRIMARY'
agorum.roi.exception.RoiException: null|Duplicate entry '2147483647' for key 'PRIMARY'
at agorum.roi.ejb.common.ExceptionUtils.get(ExceptionUtils.java:457)
at agorum.roi.ejb.common.ExceptionUtils.get(ExceptionUtils.java:398)
at agorum.roi.ejb.common.ExceptionUtils.handleException(ExceptionUtils.java:468)
at agorum.roi.ejb.common.RoiTransactionHandler.endInternal(RoiTransactionHandler.java:456)
at agorum.roi.ejb.common.RoiTransactionHandler.end(RoiTransactionHandler.java:339)
at agorum.roiwebui.editmasks.actions.GenericEditMaskSaveAction.execute(GenericEditMaskSaveAction.java:368)
at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:484)
at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:274)
at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1482)
at org.apache.struts.action.ActionServlet.doPost(ActionServlet.java:525)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
....
....

Wir konnten auch keine neuen Dokumente mehr anlegen. Nach einem Neustart des Server war das wieder möglich. Der Fehler beim Anlegen eines neuen Benutzers erscheint aber weiterhin.

Kann mir hier jemand weiterhelfen?

Freundliche Grüße
Thorsten Jahn
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#10519
tjahn (Benutzer)
Fresh Boarder
Beiträge: 2
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Aw: Fehlermeldung bei Anlage neuer Benutzer vor 3 Monaten, 2 Wochen Karma: 0  
Hallo,

ich habe die Ursache für die Fehlermeldung gefunden.
Der auto_incement Zähler der Tabelle totextindex war bei 2147483647.
Da dies noch ein Testsystem ist, habe ich den Zähler hier auf 1 gesetzt. Jetzt scheint wieder alles zu laufen.
Oder habe ich mir damit andere Probleme eingehandelt?
Ebenso bin ich mit den Tabellen totextindex1 und totextindex2 verfahren.
Im Support-Tool habe ich ein Dokument gefunden, dass nicht indexiert werden konnte und gelöscht. Evtl. kam daher der hohe Zähler?

Freundlichen Grüße
Thorsten Jahn
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
Zum Anfang gehen Neues Thema
Powered by FireBoarddie neusten Beiträge direkt auf Ihrem Desktop erhalten