Login



agorum core
Willkommen, Gast
Installation auf Windows Server 2012 R2 (1 Leser) (1) Gast
Zum Ende gehen Neues Thema Beliebt: 0
THEMA: Installation auf Windows Server 2012 R2
#9022
JBalint (Benutzer)
Fresh Boarder
Beiträge: 6
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Installation auf Windows Server 2012 R2 vor 6 Jahren, 10 Monaten Karma: 0  
Hallo zusammen,

Ich habe ein Problem:
Ich habe das Programm Agorum Core Open Source auf meinem Server installiert um es zu testen. Die ersten beiden Tage lief Agorum auch (außer das Einbinden der Netzlaufwerke), allerdings habe ich den Server von gestern auf heute über Nacht angelassen und heute Morgen konnte ich nicht mehr auf das Webinterface zugreifen, sodass ich den Server neu starten musste, allerdings ohne Erfolg. Im Anschluss habe ich Agorum versucht neu zu installieren, allerdings erhalte ich jetzt jedes Mal diese Fehlermeldung (siehe Anhang).
Agorum Core wurde bereits auf einem weiteren PC mehrfach installiert, wobei nach kurzer Zeit immer der selbe Fehler aufgetreten ist.

Ich bitte um Hilfe.

LG JBalint
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#9023
oliver.schulze (Admin)
Admin
Beiträge: 1824
graph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Geschlecht: männlich agorum core Ort: Neuhausen Geburtstag: 1978-09-17
Aw: Installation auf Windows Server 2012 R2 vor 6 Jahren, 10 Monaten Karma: 22  
Prüfen Sie mal bitte im Windows Verzeichnis unter WINDOWSDIR\system32\drivers\etc\hosts den Eintrag für roihost, passt dieser zu Ihrer IP? Wenn Sie eine dynamisch wechselnde IP Adresse haben, könnte das der Grund sein, warum es auch nicht mehr lief. Falls ja: Für den Betrieb von agorum core sollten Sie in diesem Fall mit einer statischen Adresse arbeiten.
 
Moderator informieren   Gespeichert Gespeichert  
 
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#9024
JBalint (Benutzer)
Fresh Boarder
Beiträge: 6
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Aw: Installation auf Windows Server 2012 R2 vor 6 Jahren, 10 Monaten Karma: 0  
In dieser Datei Hosts ist keinerlei Rede von einem Roihost. Die IP-Adresse ist statisch.
Kann ich den Roihost manuell nachtragen?
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#9025
jeanettesuesser (Benutzer)
Moderator
Beiträge: 723
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Geschlecht: weiblich Geburtstag: 1981-03-21
Aw: Installation auf Windows Server 2012 R2 vor 6 Jahren, 10 Monaten Karma: 11  
Hallo,

ja bitte tragen Sie den Eintrag mal nach und starten Sie agorum neu.

Code:

roihost AGORUM-IP


Allerdings ist es sehr komisch warum der Eintrag nicht drin ist, das erfolgt bei der Installation,
haben Sie sicher mit Admin-Rechten installiert?

Viele Grüße
Jeanette Süßer
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#9027
JBalint (Benutzer)
Fresh Boarder
Beiträge: 6
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Aw: Installation auf Windows Server 2012 R2 vor 6 Jahren, 10 Monaten Karma: 0  
Hallo,

Da liegt ja leider schon das Problem, ich kriege Agorum nicht mal mehr installiert. Hatte das, bevor ich Ihnen hier geschrieben habe, deinstalliert und wollte es wieder installieren, leider mit der oben angegebenen Fehlermeldung.

Gruß JBalint
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#9030
jeanettesuesser (Benutzer)
Moderator
Beiträge: 723
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Geschlecht: weiblich Geburtstag: 1981-03-21
Aw: Installation auf Windows Server 2012 R2 vor 6 Jahren, 10 Monaten Karma: 11  
Hallo,

OK Sie haben agorum deinstalliert und können Sie mal prüfen ob alles deinstalliert ist,
also bitte auch mal in den Diensten prüfen ob die agorum core Dienste deinstalliert sind.

Ggf. nach dem deinstallieren mal den Server durchstarten und eine erneute Installation versuchen.

Ist Ihr User ein Admin? Führen Sie die Anwendung bitte mal als Administrator aus (rechte Maustaste).

Viele Grüße
Jeanette Süßer
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#9031
JBalint (Benutzer)
Fresh Boarder
Beiträge: 6
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Aw: Installation auf Windows Server 2012 R2 vor 6 Jahren, 10 Monaten Karma: 0  
Hallo,

Ich habe noch Überreste gefunden, und zwar:
- war der Dienst agorumcore.mysql noch vorhanden -> gelöscht über die Registry
- Restdaten, die sich auf MySql bezogen waren im Programme(x86] noch vorhanden -> konnten erst nach dem Löschen des Diensts gelöscht werden

Danach habe ich den Server neu gestartet und die Installation erneut aufgeführt (als Administrator), allerdings erscheint der selbe Fehler. Ebenfalls bleibt, dass das automatische Rückgängigmachen der Installation "einfriert" und es manuell beendet werden muss.

JBalint
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#9032
jeanettesuesser (Benutzer)
Moderator
Beiträge: 723
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Geschlecht: weiblich Geburtstag: 1981-03-21
Aw: Installation auf Windows Server 2012 R2 vor 6 Jahren, 10 Monaten Karma: 11  
Hm, das ist sehr komisch.

Wir haben einige Installationen auf 2012er Servern und mir sind keine Probleme bekannt.

Ich würde vorschlagen Sie verwenden nicht die ausgelieferte Datenbank sondern installieren die MySQL separat und
installieren agorum dann mit Hilfe der Experteninstallation dann auf einer vorhandenen Datenbank, also die MySQL die
Sie vorbereitet haben.

Das hat auch den Vorteil, dass Sie die aktuellste Version der MySQL-Datenbank verwenden.

Bei Einrichtung der Datenbank sind bestimmte Einstellungen zu beachten, insbesondere
1. InnoDB-Engine der MySQL-Datenbank muss installiert sein
2. max_allowed_packet=2M (oder höher)
3. lower_case_table_names=1

näheres dazu finden Sie im Wiki https://www.agorum.com/wiki/index.php/MySQL

Bei Installation von agorum müssen Sie die Experteninstallation auswählen und vorhandene Datenbank.

Viele Grüße
Jeanette Süßer
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#9062
JBalint (Benutzer)
Fresh Boarder
Beiträge: 6
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Aw: Installation auf Windows Server 2012 R2 vor 6 Jahren, 9 Monaten Karma: 0  
Hallo zusammen,

Ich habe einige Male MySQL zu installieren, allerdings gab es dort Probleme mit der Verbindung. Deswegen habe ich nach langem hin und her den Server neu installiert.
Auf dem neu installierten Server habe ich erneut Agorum Core installiert und die Ports aus der Anleitung für die Firewall freigegeben, den Server habe ich im Anschluss neu gestartet. Nach dem Neustart habe ich den Agorum-Dienst gestartet, komme dann allerdings nicht mehr auf die Weboberfläche. Jegliche Neustarts der Dienste wurden durchgeführt und die htdocs-Datei wurde ebenfalls überprüft.

Nun bitte ich Sie erneut um Hilfe.

LG jbalint
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#9063
JBalint (Benutzer)
Fresh Boarder
Beiträge: 6
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Aw: Installation auf Windows Server 2012 R2 vor 6 Jahren, 9 Monaten Karma: 0  
Juhuu, es klappt endlich!

Hallo zusammen,

Die Lösung ist:
Neben den eingehenden Firewallregeln auch die Ausgehenden anzulegen.

- Regel "TCP_agorum_allow": TCP allow 80, 137, 139, 443
- Regel "UDP_allow": UDP allow 137
- Regel "TCP_agorum_block": TCP block 445 (beschränkt auf die agorum Netzwerkkarte)

Dann funktioniert der Zugriff auch ohne Probleme.

Vielen Dank für die Hilfe!

MfG jbalint
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#9064
jeanettesuesser (Benutzer)
Moderator
Beiträge: 723
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Geschlecht: weiblich Geburtstag: 1981-03-21
Aw: Installation auf Windows Server 2012 R2 vor 6 Jahren, 9 Monaten Karma: 11  
Hallo,

Ok super, dass es jetzt klappt, wobei ich in den meinen seitherigen Netzwerkumgebungen dies nicht berücksichtigen
musste.

Viel Spaß weiterhin

Viele Grüße
Jeanette Süßer
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
Zum Anfang gehen Neues Thema
Powered by FireBoarddie neusten Beiträge direkt auf Ihrem Desktop erhalten