Login



agorum core
Willkommen, Gast
ADS / LDAP Passwort-Sync (1 Leser) (1) Gast
Zum Ende gehen Neues Thema Beliebt: 0
THEMA: ADS / LDAP Passwort-Sync
#8667
JulianHamborg (Benutzer)
Fresh Boarder
Beiträge: 8
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
ADS / LDAP Passwort-Sync vor 7 Jahren, 8 Monaten Karma: 0  
Hallo!

Ich scheitere gerade daran den LDAP-Helper für Linux zu finden. Die in den anderen Threads und in der AdminSync Anleitung beschriebene LDAP-Helper ZIP-Datei ist bei mir nicht vorhanden... Wo kann man diese herunterladen. Mir fehlen konkret die scripts/setenv.sh, scripts/ldapadminsyncservice.sh, scripts/ngospasswd.sh files. Die LDAPAdminSyncService.xml konnte ich ja auch von der agorum Core Installation kopieren.

So viel zu meinem bisherigen Vorgehen und meiner Installation:

Wir setzen einen Univention UCS-Server mit Samba 4 und ADS Unterstützung ein. Von diesem sollen die Benutzer/Gruppen und die Passwörter der Benutzer synchronisiert werden. Ersteres funktioniert auch bereits. Es geht nur noch um die Passwörter... Dafür muss laut Anleitung der LDAP Helper installiert sein... Das ist noch nicht der Fall!

Agorum Core betreibe ich auf einem Linux Debian 7.

Der Agorum Core Server ist derzeit auf ADS-Sync eingestellt (nicht LDAP-Sync) mit gesetzem Passwort-Server und übereinstimmenden Crypt Key in MetaDB und LDAPAdminSyncService.xml.

Danke für Eure Hilfe!

Gruß

Julian
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#8668
jeanettesuesser (Benutzer)
Moderator
Beiträge: 723
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Geschlecht: weiblich Geburtstag: 1981-03-21
Aw: ADS / LDAP Passwort-Sync vor 7 Jahren, 8 Monaten Karma: 11  
Hallo,

den Helper gibt es nur für AD-Server für Ihr LDAP wird er nicht benötigt.

Welche Version von agorum core nutzen Sie?
Haben Sie die Konfiguration mit dem Konfigurator gemacht?

Sie sagen Benutzer und Gruppen kommen an, diese werden also in agorum angezeigt, jedoch gesperrt? Nach dem ersten synchronisieren müssen Sie das Passwort einmal ändern dann nochmal synchronisieren der geänderten Objekte und prüfen ob der User freigeschaltet ist.

QUOTE:
Der Agorum Core Server ist derzeit auf ADS-Sync eingestellt (nicht LDAP-Sync) mit gesetzem Passwort-Server und übereinstimmenden Crypt Key in MetaDB und LDAPAdminSyncService.xml.

Warum auf ADS-Sync?

Viele Grüße
Jeanette Süßer
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#8669
JulianHamborg (Benutzer)
Fresh Boarder
Beiträge: 8
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Aw: ADS / LDAP Passwort-Sync vor 7 Jahren, 8 Monaten Karma: 0  
Vielen Dank für Süßer für Ihren Beitrag/Antwort!

Wir testen gerade die vermeintlich aktuelle Version 7.1.5.

Die Konfiguration habe ich mit dem Konfigurator vorgenommen.
Dazu sind diesem Beitrag auch ein paar Screenshots beigefügt.

Die Benutzer und Gruppen werden im agorum angezeigt. Sind aber gesperrt. Genauso ist es.
Vergibt man manuell ein Passwort wird die Sperre aufgehoben.

ADS ist ein gestellt, das es schlicht mit LDAP bisher nicht funktioniert hat.
Der Konfigurator wird zwar erfolgreich beendet. Führt man die Synchronisation durch, werden keine Objekte synchronisiert. Benutzer und Gruppen habe ich auch vorher gelöscht.
Die allererste funktionierende Synchronisation wurde allerdings mit ADS durchgeführt.

Zu den Passwörtern: Einem Benutzer habe ich (in der Management Konsole des UCS) ein neues Passwort gegeben und danach sowohl das Holen der geänderten Objekte (im ersten Versuch), wie auch eine komplette neu Synchronisation (2. Versuch) bringt mit ADS keine Besserung. Auch wenn man dann die LDAP Konfiguration wählt, gehts nicht. Ich habe auch getestet, den Credential des Benutzers mit dem geänderten Passwort manuell auf die LDAP Konfiguration zu setzen und dann den Sync per LDAP auszuführen.

Auffällig ist, dass beim Klick auf AdminSync links in der Navigation dort nur ein Unterordner für ADS angelegt wurde, nicht jedoch für LDAP... Ist das Verhalten normal? Ich habe auch einmal den ADS Ordner, sowie alle vorher mit ADS synchronisierten Benutzer und Gruppen gelöscht und dann versucht die LDAP Konfiguration zu wählen...

Vielen Dank!

Beste Grüße

Julian Hamborg

 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#8670
JulianHamborg (Benutzer)
Fresh Boarder
Beiträge: 8
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Aw: ADS / LDAP Passwort-Sync vor 7 Jahren, 8 Monaten Karma: 0  
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#8671
JulianHamborg (Benutzer)
Fresh Boarder
Beiträge: 8
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Aw: ADS / LDAP Passwort-Sync vor 7 Jahren, 8 Monaten Karma: 0  
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#8672
JulianHamborg (Benutzer)
Fresh Boarder
Beiträge: 8
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Aw: ADS / LDAP Passwort-Sync vor 7 Jahren, 8 Monaten Karma: 0  
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#8673
jeanettesuesser (Benutzer)
Moderator
Beiträge: 723
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Geschlecht: weiblich Geburtstag: 1981-03-21
Aw: ADS / LDAP Passwort-Sync vor 7 Jahren, 8 Monaten Karma: 11  
Hallole,

könnten Sie bitte mal noch die Einstellungen in der MetaDb prüfen vgl.

https://www.agorum.com/wiki/index.php/AdminSync_Konfiguration#Samba-Schema-_bzw._UCS-Synchronisation


Viele Grüße
Jeanette Süßer
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#8676
JulianHamborg (Benutzer)
Fresh Boarder
Beiträge: 8
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Aw: ADS / LDAP Passwort-Sync vor 7 Jahren, 8 Monaten Karma: 0  
Hallo,

ja das war bereits richtig gesetzt...

Gibt es eine Möglichkeit die Konfigurationen von dem Admin Sync Modul vollständig zu löschen?
Sodass man es einfach noch mal von vorne direkt mit LDAP probieren kann? Vielleicht hat sich da ja irgendwas festgefahren?

Vielen Dank!

Gruß

 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#8677
jeanettesuesser (Benutzer)
Moderator
Beiträge: 723
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Geschlecht: weiblich Geburtstag: 1981-03-21
Aw: ADS / LDAP Passwort-Sync vor 7 Jahren, 8 Monaten Karma: 11  
Hallo,

handelt es sich um ein Testsystem oder ein Produktivsystem?

Sie können die Konfig in der MetaDb löschen, das sind die Konfigurationsdaten die der Konfigurator anlegt.

Ich werde mich nochmal auf die Suche machen nach möglichen weiteren Punkten.

Grüße
Jeanette Süßer
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#8684
JulianHamborg (Benutzer)
Fresh Boarder
Beiträge: 8
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Aw: ADS / LDAP Passwort-Sync vor 7 Jahren, 8 Monaten Karma: 0  
Hallo,

es handelt sich im Falle des AgorumCore Servers um ein Testsystem auch nur mit Test-Lizenz... Der UCS Server bei uns ist Produktiv im Einsatz.

Ich habe nun alle Einträge von dem Sync-Modul aus der MetaDB gelöscht und im Konfiguration eine neue Konfiguration angelegt...

Dazu muss ich sagen, dass Agorum Core das erste System ist, dass wir an den LDAP Server von Außen anbinden wollen, ich habe noch keine weiteren Geräte, die sich am LDAP-Server anmelden und Benutzer/Passwörter abrufen. Bis auf zwei Linux-Debian Systeme, die in der Domäne sind und eine User/Group-Syncronisation auch mit Passwörtern bereits erfolgreich abrufen können. Da es sich darum aber um einen Samba-Domänen Beitritt handelt, gehe ich davon aus, dass die Anmeldung in diesem Fall auf eine andere Art und Weise erfolgt?

Mit der neuen Konfiguration komme ich nun soweit, dass die Anmeldung am Server klappt. Zumindest komme ich bis zur zweiten Konfigurationsseite, wo die Pfade für die Syncronisation zugewiesen werden.
Leider kann er die LDAP-Struktur unseres LDAP-Masters nicht abrufen... Er dreht sich oben ewig der kleine Kreis...

Auch in der jetzt neu angelegten LDAP-Konfiguration ist die "2" in den Einträgen vorhanden. Den Cryptkey habe ich auch noch einmal überprüft... und die Anmeldung am LDAP Server habe ich nun mit dem Administratorbenutzer des LDAP Moduls durchgeführt (Original UCS Konfiguration) vorher war es der Administratorbenutzer, der auch Windows-Admin und sich in einer von uns angelegten OU befindet).

Ich werde mich nun noch mal mit dem UCS Server auseinander setzen müssen und testen ob der Zugriff auf den LDAP Server mit einem Konsolentool funktioniert.
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#8699
jeanettesuesser (Benutzer)
Moderator
Beiträge: 723
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Geschlecht: weiblich Geburtstag: 1981-03-21
Aw: ADS / LDAP Passwort-Sync vor 7 Jahren, 8 Monaten Karma: 11  
Hallo JulianHamborg,

ich war ein paar Tage nicht im Büro, wie ist denn der Stand bei Ihnen?

Viele Grüße
Jeanette Süßer
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#8702
JulianHamborg (Benutzer)
Fresh Boarder
Beiträge: 8
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Aw: ADS / LDAP Passwort-Sync vor 7 Jahren, 8 Monaten Karma: 0  
Hallo Frau Süßer,

vielen Dank für Ihre Frage nach dem Stand. Ich werde leider erst am Wochenende wieder dazu kommen, mich mit dem Thema zu beschäftigen.
Sobald ich weis, dass der Abruf der LDAP-Datenbank auf unserem UCS Server richtig funktioniert, melde ich mich wieder.

Wir haben bereits zwei Linux Debian Systeme mit Samba 4 im Einsatz, die Mitglied der Domäne sind und sich erfolgreich die Benutzer/Passwörter der Nutzer vom UCS Server abholen.
Auf der anderen Seite haben wir einen Netzwerkscanner, mit dem wir erste Versuche unternommen haben, ihn ebenfalls das LDAP-Verzeichnis abzurufen, dass ähnlich ins leere läuft. Die Authentifizierung am LDAP-Server scheint zu klappen, aber es erscheinen keine Inhalte / Struktur.

Es kann nun entweder ein Konfigurationsfehler auf der Serverseite oder in den Konfig bei dem abrufenden Client (Agorum Core / Netzwerkscanner) sein.
LDAP ist für mich ein halbwegs neues Thema, daher kann ich einen Konfigurationsfehler nicht vollständig ausschließen.
Falls Sie einen Link zu einer guten und umfassenden Anleitung/Literatur zu dem Thema wissen, wäre ich auch darüber sehr froh.

Vielen Dank für Ihre Unterstützung!

Beste Grüße

Julian Hamborg
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
Zum Anfang gehen Neues Thema
Powered by FireBoarddie neusten Beiträge direkt auf Ihrem Desktop erhalten