Login



agorum core
Willkommen, Gast
Aw: 2 Netzwerkkarten unter VM Appliance (1 Leser) (1) Gast
Hier kommt alles rein, was mit der Virtual Appliance von agorum core zu tun hat
Zum Ende gehen Neues Thema Beliebt: 0
THEMA: Aw: 2 Netzwerkkarten unter VM Appliance
#5968
nmaj (Benutzer)
Fresh Boarder
Beiträge: 2
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
2 Netzwerkkarten unter VM Appliance vor 8 Jahren, 3 Monaten Karma: 0  
Hallo erstmal,

im einsatz habe ich die agorum-core-appliance 6.4.8
ich habe folgendes Problem ich hätte gerne die agorum Dienste auf 2 Netzwerkkarten.

Netzwerkkarte eth0 192.168.0.1
diese Karte ist über die Option Netzwerk konfigurieren eingerichtet
hier funktioniert alles wie gewünscht.

Netzwerkkarte eth1 172.31.26.1
auf dieser Karte ist der webServer mit dem agorum gui ebenfalls erreichbar. Jedoch ist weder ftp noch smb noch webdav über diese ip erreichbar.

Wie konfiguriere ich die vm appliance so das die Dienste auf beiden Netzwerkkarten erreichbar sind?

Hoffe auf Hilfe
Gruß nmaj
 
Moderator informieren   Gespeichert Gespeichert  
 
Letzte Änderung: 12.05.2011 11:52 von nmaj.
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#5975
frank.stettner (Benutzer)
Moderator
Beiträge: 1296
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Geschlecht: männlich agorum core Ort: Stuttgart Geburtstag: 1979-09-06
Aw: 2 Netzwerkkarten unter VM Appliance vor 8 Jahren, 3 Monaten Karma: 18  
Hallo.

Außer den Protokollen SMB/CIFS und FTP sind die anderen Protokolle (HTTP(S), WebDAV, IMAP(S), SMTP, SMTPExtern(S)) über alle Interfaces erreichbar.

Für FTP ändern Sie in der MetaDB unter /MAIN_MODULE_MANAGEMENT/roiprotocols/ftp/control die beiden Einträge SelfAddress und ServerAddress von roihost in 0.0.0.0 und für SMB unter /MAIN_MODULE_MANAGEMENT/roiprotocols/smb/control den Eintrag BindAddress von roihost in 0.0.0.0

Jetzt noch den agorum Dienst neu starten und SMB/CIFS und FTP horchen auf allen Interfaces.

Kontrollieren können Sie das mit dem Befehl
Code:

netstat -anp


Achtung: Wir empfehlen FTP nicht für normale Benutzer frei zu geben, da z.b. XML-Dateien nach dem hoch kopieren sofort geparst werden...

Viele Grüße
Frank Stettner
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#5980
nmaj (Benutzer)
Fresh Boarder
Beiträge: 2
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Aw: 2 Netzwerkkarten unter VM Appliance vor 8 Jahren, 3 Monaten Karma: 0  
Danke hat alles geklappt
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#6421
mephloneu (Benutzer)
Fresh Boarder
Beiträge: 3
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Aw: 2 Netzwerkkarten unter VM Appliance vor 8 Jahren Karma: 0  
Hallo,

ich reaktiviere diesen Thread mal weil ich eine Frage habe die das genaue Gegenteil betrifft.
Kann ich irgendwo einstellen dass der hhtp bzw https Zugriff des desk4web nur auf einem Interfacce lauscht=

Hintergrund ist der dass ich auf dem selben Server noch gerne einen apache laufen lassen würde, diesen aber auch auf den Standardports verwenden möchte.
Über Hilfe würde ich micht sehr freuen!

Viele Grüße,
MephLo
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#6429
andreas.wild (Admin)
Admin
Beiträge: 281
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Aw: 2 Netzwerkkarten unter VM Appliance vor 8 Jahren Karma: 3  
Hallo,

Sie können das Interface, auf dem der agorum-eigene Webserver läuft anpassen, indem Sie im Startskript (../agorumcore/scripts/roi_jboss) in der Zeile

Code:

nohup "${INSTDIR}/jboss/bin/run.sh" &


vor dem "&" folgenden Parameter einfügen:

Code:

-b <IP-Adresse des Interfaces>
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#6436
mephloneu (Benutzer)
Fresh Boarder
Beiträge: 3
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Aw: 2 Netzwerkkarten unter VM Appliance vor 8 Jahren Karma: 0  
Hallo,

vielen Dank für die Hilfe. Habe die Änderung nun eingepflegt, sieht so aus:
Code:

nohup "${INSTDIR}/jboss/bin/run.sh" -b 192.168.20.10&


Die Änderung hat sich auf auch auf den HTTP- Server (Port 80) ausgewirkt, dieser läuft nun nur noch auf der IP 192.168.20.10, der HTTPS-Server (Port 443) antwortet aber immer noch auf allen Interfaces....
Wie kann ich denn auch den HTTPS- Server an mein Interface binden?

die Ausgabe von
Code:

netstat -anp | grep 443
ergibt:
Code:

tcp 0 0 :::443 :::* LISTEN 29204/java
Und zeigt damit den Effekt, zu diesem Zeitpunkt lief kein anderer Webserver.
 
Moderator informieren   Gespeichert Gespeichert  
 
Letzte Änderung: 17.08.2011 19:39 von mephloneu.
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#6439
andreas.wild (Admin)
Admin
Beiträge: 281
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Aw: 2 Netzwerkkarten unter VM Appliance vor 8 Jahren Karma: 3  
Hallo,

damit sich die Änderung auch auf den HTTPS-Port auswirkt, ändern Sie in der Datei

Code:


../agorumcore/jboss/server/default/deploy/jbossweb-tomcat41.sar/META-INF/jboss-service.xml



den folgenden Tag

Code:


<Connector className="org.apache.coyote.tomcat4.CoyoteConnector"
port="443" maxThreads="150" minProcessors="5" maxProcessors="75"
enableLookups="true"
acceptCount="100" compression="on" debug="0" scheme="https" secure="true"
useURIValidationHack="false" disableUploadTimeout="true">



so ab, dass er wie folgt aussieht (Attribut "address" ergänzen):

Code:


<Connector className="org.apache.coyote.tomcat4.CoyoteConnector"
address="${jboss.bind.address}" port="443" maxThreads="150" minProcessors="5" maxProcessors="75"
enableLookups="true"
acceptCount="100" compression="on" debug="0" scheme="https" secure="true"
useURIValidationHack="false" disableUploadTimeout="true">

 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#6444
mephloneu (Benutzer)
Fresh Boarder
Beiträge: 3
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Aw: 2 Netzwerkkarten unter VM Appliance vor 8 Jahren Karma: 0  
Hallo,

vielen Dank! Funktioniert super Wenn man den Tomocat erst mal gefunden hat kann man ihn auch konfigurieren

Viele Grüße,
Meph
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
Zum Anfang gehen Neues Thema
Powered by FireBoarddie neusten Beiträge direkt auf Ihrem Desktop erhalten