Login



agorum core
Willkommen, Gast
Aw: DMS-Laufwerk Ubuntu: mount error(115): Operation n (1 Leser) (1) Gast
Zum Ende gehen Neues Thema Beliebt: 0
THEMA: Aw: DMS-Laufwerk Ubuntu: mount error(115): Operation n
#9518
Guntram (Benutzer)
Fresh Boarder
Beiträge: 17
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
DMS-Laufwerk Ubuntu: mount error(115): Operation n vor 5 Jahren, 9 Monaten Karma: 0  
Hallo!

Ich habe agorumcore auf einem Ubuntu 14.04 64-Bit Server installiert und versuche, auf das DMS-Laufwerk von meinem Ubuntu 14.04-Client zuzugreifen.

Leider bekomme ich nach

Code:

sudo mount -t cifs //IpDesServers/dms /mnt/dms -o username=roi,sec=ntlm,iocharset=utf8,uid=1000,gid=1000 --verbose

und Passworteingabe die wenig aussagekräftige Meldung:
QUOTE:
mount error(115): Operation now in progress


Wenn ich den gleichen Befehl auf dem Server selber ausführe, funktioniert es. Es muß also ein Problem mit der Verbindung nach draußen geben.

Firewall (ufw) habe ich testweise abgeschaltet - kein Unterschied.

Woran kann das noch liegen bzw. wie kann ich das Problem suchen? Ist das Laufwerk denn überhaupt ein "echter" Samba-Share (bzw. nutzt agorumcore die samba-Funktionen des Betriebssystems?)?
Mein desk4weg läuft auf Port 81 (80 ist schon mit apache belegt) und ist übers Netz erreichbar.

Vielen Dank für Anregungen,
Guntram
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#9519
jeanettesuesser (Benutzer)
Moderator
Beiträge: 723
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Geschlecht: weiblich Geburtstag: 1981-03-21
Aw: DMS-Laufwerk Ubuntu: mount error(115): Operation n vor 5 Jahren, 9 Monaten Karma: 11  
Guten Morgen,

da Sie die Firewall bereits ausgeschlossen haben gehe ich davon aus, dass auf dem Server ein Samba installiert ist und es dadurch einen Konflikt mit unserem DMS-Laufwerk gibt, denn wir nehmen nicht den Samba des Betriebssystems.

Im Wiki finden Sie passende Konfigurationshinweise wenn ein Samba auf dem agorum core Server betrieben wird, wichtig, es funktioniert dann nur mit zwei Netzwerkkarten. Es gibt einen Portkonflikt daher müssen wir eine für den Samba und eine für agorum core verwenden

https://www.agorum.com/wiki/index.php/Systemkonfiguration_mit_Samba

Viele Grüße
Jeanette Süßer
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#9523
Guntram (Benutzer)
Fresh Boarder
Beiträge: 17
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Aw: DMS-Laufwerk Ubuntu: mount error(115): Operation n vor 5 Jahren, 9 Monaten Karma: 0  
Guten Morgen Frau Süßer,

nein - es ist kein Samba installiert. agorumcore hört auch fleißig auf Port 139.
Ebenso ist der Eintrag in der /etc/hosts vorhanden. Mein Setup verfügt ansonsten auch nur über eine Netzwerkkarte.

Alles, was ich bisher zu analogen Problemen mit Samba gefunden habe, deutet auch irgendwelche NetBIOS oder Hostnamenprobleme hin. Da agorum ja aber seinen eigenen Samba-Server implementiert, kann ich da (wohl?) nichts an den enstprechenden Konfigurationsdateien ändern .

Gibt es noch weitere Ideen?

Danke,
Ihr Guntram Schmidt
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#9524
jeanettesuesser (Benutzer)
Moderator
Beiträge: 723
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Geschlecht: weiblich Geburtstag: 1981-03-21
Aw: DMS-Laufwerk Ubuntu: mount error(115): Operation n vor 5 Jahren, 9 Monaten Karma: 11  
Hallo,

können Sie mir mal von so einem Versuch das Server-Log schicken, damit ich sehen kann ob bei uns überhaupt etwas ankommt

Code:

InstallDir/jboss/server/default/log/server.log


Viele Grüße
Jeanette Süßer
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#9525
Guntram (Benutzer)
Fresh Boarder
Beiträge: 17
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Aw: DMS-Laufwerk Ubuntu: mount error(115): Operation n vor 5 Jahren, 9 Monaten Karma: 0  
Hallo,

wenn ich mich von einem entfernten Rechner verbinden will, passiert nichts im Log. Bei lokalem mount-Versuch (also direkt auf dem Server), erhalte ich "SMBLogging: new SmbConnThread" etc. ...

Ich habe jetzt mal smbclient ausprobiert. Lokal erhalte ich jeweils nach Passworteingabe:

- für smbclient -L //domain.tld -U roi
QUOTE:

Connection to domain.tld failed (Error NT_STATUS_UNSUCCESSFUL)

und analog für smbclient -L //localhost -U roi

- für smbclient -L //127.0.0.1 -U roi
QUOTE:

Connection to 127.0.0.1 failed (Error NT_STATUS_CONNECTION_REFUSED)



- für smbclient -L //37.120.169.36 -U roi
QUOTE:

Domain=[WORKGROUP] OS=[Windows XP 3790 Service Pack 2] Server=[Windows XP 5.2]

Sharename Type Comment
--------- ---- -------
cli_rpc_pipe_open_noauth: rpc_pipe_bind for pipe \srvsvc failed with error NT_STATUS_IO_DEVICE_ERROR
load Disk d
privat Disk M
root Disk R
files Disk F
dms Disk D
TestDynamicSha Device
 Disk
B Disk
Domain=[WORKGROUP] OS=[Windows XP 3790 Service Pack 2] Server=[Windows XP 5.2]

Server Comment
--------- -------

Workgroup Master
--------- -------


Analoge Versuche von einem externen Rechner ergeben nur Error NT_STATUS_IO_TIMEOUT für IP resp. Domainname.

Meine hosts-Datei
QUOTE:

cat /etc/hosts
127.0.0.1 localhost

# The following lines are desirable for IPv6 capable hosts
::1 localhost ip6-localhost ip6-loopback
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
IP langeZahlenKombi.yourvserver.net langeZahlenKombi roihost

#IP roihost


Ich habe roihost gemäß den Empfehlungen direkt als Alias für die fest IP eingetragen und die automatisch angelegte Zeile auskommentiert - das hat aber nichts am Verhalten geändert.

Vielen Dank schon Mal für Ihre Hilfe. Vielleicht hilft das obige ja, das Problem weiter einzugrenzen?
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#9530
jeanettesuesser (Benutzer)
Moderator
Beiträge: 723
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Geschlecht: weiblich Geburtstag: 1981-03-21
Aw: DMS-Laufwerk Ubuntu: mount error(115): Operation n vor 5 Jahren, 8 Monaten Karma: 11  
Hallo,

hm das mit dem roihost-Eintrag habe ich noch nicht ganz verstanden und dieser ist elementar für die Verbindung, da dieser bei den ganzen Verbindungsparametern in der MetaDb als Platzhalter verwendet wird.

Können Sie mir bitte ein ganzes Log schicken, dann sehe ich normalerweise ob das das Problem ist.

Grüße
J. Süßer
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#9532
Guntram (Benutzer)
Fresh Boarder
Beiträge: 17
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Aw: DMS-Laufwerk Ubuntu: mount error(115): Operation n vor 5 Jahren, 8 Monaten Karma: 0  
Voilà: https://guntramschmidt.fr/owncloud/index.php/s/hz0N9DeZVrxFNrb

Habe einfach den kompletten log-Ordner kopiert.

Wäre toll, wenn Sie das Problem aufspüren könnten!

Einen guten Wochen-Endspurt,
Guntram Schmidt
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#9534
jeanettesuesser (Benutzer)
Moderator
Beiträge: 723
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Geschlecht: weiblich Geburtstag: 1981-03-21
Aw: DMS-Laufwerk Ubuntu: mount error(115): Operation n vor 5 Jahren, 8 Monaten Karma: 11  
Hallo,

alles klar download hat geklappt ich schaue es mir an.

Grüße
Jeanette Süßer
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#9535
Guntram (Benutzer)
Fresh Boarder
Beiträge: 17
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Aw: DMS-Laufwerk Ubuntu: mount error(115): Operation n vor 5 Jahren, 8 Monaten Karma: 0  
Alles klar - habe den Ordner wieder privatisiert !

Könnten Sie bei Gelegenheit noch im obigen Post bei

"- für smbclient -L //*.*.*.* -U roi"

die IP-Adresse maskieren? Kann den Beitrag nicht editieren.

Danke,
Guntram Schmidt
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#9545
jeanettesuesser (Benutzer)
Moderator
Beiträge: 723
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Geschlecht: weiblich Geburtstag: 1981-03-21
Aw: DMS-Laufwerk Ubuntu: mount error(115): Operation n vor 5 Jahren, 8 Monaten Karma: 11  
Hallo,

können Sie mal im desk4web unter Benutzereinstellungen das roi-PW neu setzen und, agorum durchstarten, warten bis es sauber hochgefahren ist und 1 Versuch vom Server machen (positiv) und einem vom Client.

Davon benötige ich dann das Log.

Viele Grüße
Jeanette Süßer
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
Zum Anfang gehen Neues Thema
Powered by FireBoarddie neusten Beiträge direkt auf Ihrem Desktop erhalten