Login



agorum core
Willkommen, Gast
Aw: CIFS ohne Funktion / zwei NIC / nach WIKI install. (1 Leser) (1) Gast
Zum Ende gehen Neues Thema Beliebt: 0
THEMA: Aw: CIFS ohne Funktion / zwei NIC / nach WIKI install.
#10183
CSG (Benutzer)
Fresh Boarder
Beiträge: 3
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
CIFS ohne Funktion / zwei NIC / nach WIKI install. vor 2 Jahren, 11 Monaten Karma: 0  
Hallo zusammen,

wir haben einen Testserver unter Win Server 2016 Std. unter VMware installiert.
NIC01: 172.16.0.21 für UNC-Zugriff CIFS
NIC02: 172.16.0.22 für WebZugriff

Der WebZugriff funktioniert über NIC02.
Auch der Testweise Zugriff auf eine Windows-Freigabe funktioniert über NIC02.

Auf NIC01 ist deaktiviert:
- NetBios via TCP/IP auf IPv4
- Client für Microsoft-Netzwerke
- Datei- und Druckerfreigabe

In der HOSTS-Datei steht als roihost die IP 172.16.0.21 der NIC01.

Als Firewall-Block-Regel steht unter eingehende Regeln der Port 445 TCP für die NIC01.
Als Firewall-Allow-Regel steht unter eingehenden Regeln der Port 139 TCP für die NIC01.

Auf dem Client ist nichts installiert.

Ein Zugriff auf \\172.16.0.21 sowie \\172.16.0.21\dms schlägt mit der typischen Windows-Fehlermeldung fehl, wenn ein UNC-Pfad nicht gefunden werden kann.

Ist Port 445 auf NIC01 aktiv kann die testweise Windows-Freigabe erreicht werden, welche sonst nur über NIC02 erreichbar ist.

Ach so: Serverversion setup-agorum-core-server-open-8_3_0_4-1757.exe

So, irgendwas mach ich ja trotzdem noch falsch.

Könnt Ihr mir dabei helfen?

VG und danke,

Jan
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#10184
CSG (Benutzer)
Fresh Boarder
Beiträge: 3
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Aw: CIFS ohne Funktion / zwei NIC / nach WIKI install. vor 2 Jahren, 10 Monaten Karma: 0  
Hallo, kann mir da jemand im Forum weiterhelfen?
Wäre super.
Ich glaube, alles korrekt gemacht zu haben und finde nicht heraus, wo mein Fehler liegt.
VG
Jan
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#10185
jeanettesuesser (Benutzer)
Moderator
Beiträge: 723
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Geschlecht: weiblich Geburtstag: 1981-03-21
Aw: CIFS ohne Funktion / zwei NIC / nach WIKI install. vor 2 Jahren, 10 Monaten Karma: 11  
Hallo,

Sie müssen den Web-Zugriff nicht vom cifs- Zugriff trennen der WebServer binded typischerweise auf beide Adressen.

Die Konfig die Sie beschreiben bezieht sich darauf, dass Sie SMBv1 nutzen wollen, das sollte auch noch funktionieren, allerdings an dieser Stelle der Hinweis, dass Sie ab der genannten Version auch das SMBv2 Protokoll nutzen könnten, dann ist die Konfig allerdings anders. Einen entsprechenden Hinweis finden Sie in der Installationanleitung oder aber direkt unter folgendem Link https://agorumdocproxy.agorum.com/roiwebui/acds_module/doc?id=700592259

Ansonsten würde ich bei der Verbindung vom Client aus empfehlen explizit zu sagen, dass Sie sich mit anderen Anmeldedaten anmelden wollen oder über die Konsole (net use) explizit den gewünschten agorum core User mitgeben.

Grüße
Jeanette Süßer
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#10191
CSG (Benutzer)
Fresh Boarder
Beiträge: 3
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Aw: CIFS ohne Funktion / zwei NIC / nach WIKI install. vor 2 Jahren, 10 Monaten Karma: 0  
Hallo Frau Süßer,

aber ich möchte den Dienst doch nicht beenden, da ich über NIC02 ja evtl. später noch typische Windows-Freigaben nutzen möchte.
Das ist der Grund für zwei NIC gem. WIKI.
Deshalb habe ich doch auf NIC01 den Port TCP445 in der Firewall blockiert, so dass das Fallback auf TCP139 für den agorum-CIFS-Zugriff greifen sollte.

Und wenn ich auf eine CIFS-Freigabe , egal ob im Explorer oder per net use keinen User mitgebe sollten doch, analog zu einer Windows-CIFS-Verbindung die Credentials abgefragt werden, oder nicht?

VG

Jan Reichelt
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#10192
jeanettesuesser (Benutzer)
Moderator
Beiträge: 723
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Geschlecht: weiblich Geburtstag: 1981-03-21
Aw: CIFS ohne Funktion / zwei NIC / nach WIKI install. vor 2 Jahren, 10 Monaten Karma: 11  
Hallo Herr Reichelt,

wenn Sie in Zukunft SMBv2 nutzen wollen (da kommen Sie vermutlich irgendwann nicht drum herum) dann muss der Dienst zwingend deaktiviert werden, eine Windowsfreigabe ist dann nicht mehr möglich. Aber je nachdem für was Sie es brauchen müssen Sie das Konzept nur drehen, denn Sie können ja weiterhin andere Freigaben verbinden, sollte das z. B. für Backups usw. erforderlich sein.

Und zu dem zweiten Punkt, dass wenn man nichts mitgibt eigentlich die Credentials abgefragt werden sollten, ja prinzipiell stimme ich Ihnen da zu, die Praxis zeigt aber, dass das auch mal nicht passiert und aus unerklärlichen Gründen es aber funktioniert wenn diese explizit mitgegeben werden.

So wie Sie die serverseite von agorum im Moment konfiguriert haben wird versucht werden das SMBv1 Protokoll zu verwenden, was für einen Client verwenden Sie? Bei Windows 10 Clients wurde das SMBv1 Protokoll mit dem Update im April abgeschaltet, das müssten Sie erst auf dem Client wieder explizit erlauben (über die Windows Features).

Grüße
Jeanette Süßer
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
Zum Anfang gehen Neues Thema
Powered by FireBoarddie neusten Beiträge direkt auf Ihrem Desktop erhalten