Login



agorum core
Willkommen, Gast
Aw: Problem beim Starten von Agorumcore 8.0.4 / 8.1.7 (1 Leser) (1) Gast
Zum Ende gehen Neues Thema Beliebt: 0
THEMA: Aw: Problem beim Starten von Agorumcore 8.0.4 / 8.1.7
#10091
MYG (Benutzer)
Fresh Boarder
Beiträge: 5
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Problem beim Starten von Agorumcore 8.0.4 / 8.1.7 vor 3 Jahren, 8 Monaten Karma: 0  
Wir haben auf einer VMWARE-basierten VM ein Opensuse x64 42.2 laufen und bisher war ein Agorumcore 8.0.4 installiert - funktionierte bisher problemlos.

Seit Samstag konnte der Server nach dem Backup nicht mehr starten.

"Caused by: agorum.roi.exception.RoiException: null|java.util.concurrent.TimeoutException: Could not connect to ZooKeeper localhost:9981/solr within 10000 ms"

Ich habe dann einen Update auf 8.1.7 gemacht - der auch erfolgreich war - jedenfalls keine Fehler beim Update ausgeworfen hat - und der Fehler bleibt bestehen.

Von der VM gibt es einen Snapshot vor dem update auf 8.1.7

Was können wir tun?

Server-Log anbei

Gruß
Martin
Dateianhang:
Dateiname: server-a8d0843dc0824fdf14095814f436011c.zip
Dateigröße: 23747
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#10122
oliver.schulze (Admin)
Admin
Beiträge: 1824
graph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Geschlecht: männlich agorum core Ort: Neuhausen Geburtstag: 1978-09-17
Aw: Problem beim Starten von Agorumcore 8.0.4 / 8.1.7 vor 3 Jahren, 6 Monaten Karma: 22  
Der Port 8981 ist bereits belegt, vermutlich laufen noch Java Prozesse, einfach mal alle killen und nochmals probieren.
 
Moderator informieren   Gespeichert Gespeichert  
 
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
#10123
MYG (Benutzer)
Fresh Boarder
Beiträge: 5
graphgraph
Benutzer offline Hier klicken, um das Profil dieses Benutzers zu sehen
Aw: Problem beim Starten von Agorumcore 8.0.4 / 8.1.7 vor 3 Jahren, 6 Monaten Karma: 0  
Hab es!
Im zookeeper-Log (agorumcore/zookeeper/zookeeper.out) sieht man einen Java Heap Memory overflow. Hier war die Speichereinstellung von Agorum wohl zu HOCH gewählt. Dadurch konnte der Prozess zookeeper nicht gestartet werden. Der hatte dann nicht mehr genug heap frei. Das kann man auch wunderbar auf der Apache how-to-Seite nachlesen.

Ich habe bei einem 8GB system den agorum Speicher auf 6000 MB eingestellt. Jetzt läuft es. Siehe auch https://www.agorum.com/wiki/index.php/JDK_Einstellungen

Fall geschlossen...

Danke auch an Oliver Schulze für den Tip
 
Moderator informieren   Gespeichert Gespeichert  
  Kein öffentlicher Schreibzugriff erlaubt, bitte erst registrieren!
Zum Anfang gehen Neues Thema
Powered by FireBoarddie neusten Beiträge direkt auf Ihrem Desktop erhalten